MUZECAST FORUM

Notification

Icon
Error

Skibisky Offline
#1 Posted : Sunday, January 28, 2018 3:59:38 PM(UTC)
Skibisky

Rank: Member

Groups: Registered
Joined: 2/12/2016(UTC)
Posts: 2

Trying to play songs I've played before (they have a green dot) through this proxy server.

After connecting to the proxy I can play 1 or 2 songs before it starts skipping songs and comes up with the "too many errors, playback stopped."
Seems like it's secretly recaching songs that have green dots and failing once I connect through the proxy.

This happens both then the proxy server is on the same computer as the Muzecast server and when I use a proxy on another network.

Enable Local WiFi Mode is "checked" according to this post.
Do not configure firewall is unchecked.
Port 30344 is allowed through my firewall.
Port 30344 is forwarded through my modem/router, and visible.

Home computer status occasionally says "Connected" in the menu, but when I try to view it in Settings > Media Servers > My Home Computer it will be unable to connect.
http://wcf.muzecast.com/...hService.svc/ValidateUrl returns true for my IP when not run through the proxy.
Sponsor
Muzecast Support Offline
#2 Posted : Monday, January 29, 2018 5:32:03 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,191
United States
Location: United States

Thanks: 14 times
Was thanked: 138 time(s) in 131 post(s)
Looking into it.... Will let you know if I need more information from your if I will not be able to reproduce this problem.
Thank you.

Muzecast Support.
Muzecast Support Offline
#3 Posted : Monday, January 29, 2018 8:59:59 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,191
United States
Location: United States

Thanks: 14 times
Was thanked: 138 time(s) in 131 post(s)
Open Muzecast configurator and check the box ON - "Disable Firewall/Router configuration". This will help with connectivity issue, because you are going via some kind of custom proxy.

About caching.
If you have different quality settings for Mobile and WiFi streaming, whichever is the best quality will override and re-cache song if it was previously cached using lower quality.
Songs with lower quality will not trigger re-caching of the same song if it was cached with higher quality;

Re-caching can happen also if you are playing playlist in gapless mode(neither Shuffled or a Mix). When songs are played in Gapless mode, Album ReplayGain value is used to cache a song. When the same song is playing in Shuffle or a Mix mode, Track ReplayGain cached song is used.

To avoid this (if you need to avoid this), open Muzecast Settings->Advanced->Use Album Replay Gain option set it to Checked. In that case all songs will be cached using Album ReplayGain volume.

For example, if you have a song, which is part of the Album and it has Track ReplayGain = -8dB and AlbumReplayGain = -6dB. When you start playing this Album using Play button, all songs from this Album will be played in Gapless Mode and Album Replay Gain (-6dB) will be used to modify downloaded song volume while streaming. If you start playing this Album in Shuffle Mode, or click button "Shuffle" on Player screen, the same song will be re-cached using Track Replay Gain (-8dB), even though it was showing with green dot in the songs list of the Album. If you set the option I mentioned above to ON, Shuffle Mode and Gapless Mode will use only -6dB Replay Gain value and song will not be re-cached when modes are changed.
Thank you.

Muzecast Support.
Skibisky Offline
#4 Posted : Monday, January 29, 2018 4:12:35 PM(UTC)
Skibisky

Rank: Member

Groups: Registered
Joined: 2/12/2016(UTC)
Posts: 2

Hi, thanks for your quick response.

I have automatic app updates off by default, and Use Album Replay Gain wasn't in my version of the app, so I updated and turned it off. We'll see how that goes with also setting all the streaming qualities the same.

Otherwise, the updated version seems to have removed the ability to specify the URL/IP of 'My Home Computer'.

I've now checked 'Disable Firewall/Router configuration', still on 30344 with firewall and port forwarding setup.

Just to reiterate, the two situations I have are:
1. My phone is connected to the internet via a proxy running on the same machine as the Muzecast server, the server is not proxied.
2. My phone is connected to the internet via a proxy running on a machine on a different network from the Muzecast server, the server is not proxied.

I may have once got 1 to work when I fooled my phone into connecting to the server by saying the URL/IP was '127.0.0.1' or hacked a loop-back into my hosts file, but the option to manually specify a server URL in the new App is gone :(

When I connect with no proxy it comes up with 'Connected to: Muzecast Proxy'.
Then when I try through the proxy it stays as 'Connected to: Connection error.' and the status in the sidebar is 'Check Failed'.
This happens with 'Disable Firewall/Router configuration' both checked and unchecked.
It seems to be pinging http://wcf.muzecast.com/...0.1&ip=0%3A0%3A0%3A0
Where before the /ValidateUrl actually contained my servers URL/IP.
It then seems to sometimes hit up http://api.muzecast.com/mobile/utility/CheckHome/ followed by http://api.muzecast.com/mobile/utility/LogError/

Then occasional requests to http://api.muzecast.com/mobile/track/info/ which always seem to come back as 404.

Manually requesting track/info/ with a http utility responds with a 200 OK and the correct information.

I'll do some more digging in the proxy to make sure it's Http/1.1ing correctly, but I'm curious about why /GetBaseUri is ringing 192.168.0.1, and why /track/info is 404ing through the proxy but 200ing when I manually ping it.
Muzecast Support Offline
#5 Posted : Monday, January 29, 2018 4:30:25 PM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,191
United States
Location: United States

Thanks: 14 times
Was thanked: 138 time(s) in 131 post(s)
When you switch connection mode on Muzecast Server Configurator (Check box to Disable firewall config) it is better to restart Muzecast Player on your phone.
Thank you.

Muzecast Support.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.