MUZECAST FORUM

Notification

Icon
Error

gguerra333 Offline
#1 Posted : Monday, April 24, 2017 6:06:25 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Lately, I have been having this happen. Playback from a playlist or folder will stop right in the middle of the song. It is not a streaming issue and the file is already cached. It does it on wifi and 4G. When I go to the now playing screen it is as if I had pressed the pause button. I press play and it starts up again for a while until it happens again. I found out during my workouts which are about an hour a day. It does it on earphones and bluetooth. It does it about 2 or 3 times per hour. This is a new issue, had not happened in the past.
Sponsor
Muzecast Support Offline
#2 Posted : Monday, April 24, 2017 9:26:56 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
Last update to Muzecast was on March 30th. If this started to happen right after an update, I would have to take a look if any errors were sent. Also you can check Error Log in Muzecast app: Muzecast Settings->About->Error Log.

If this started to happen way after Muzecast update, then it might be outside factors which might be as follows:
1. Connection to your headset is getting interrupted, which causing Android to send a signal something like: ACTION_AUDIO_BECOMING_NOISY - meaning headset or Bluetooth headset is unplugged. Muzecast will pause playback during that signal to avoid laud music playback on a speaker (per Google guidelines);
2. Bluetooth connection dropped, which would cause the same signal been sent;
3. Another app, which you might installed lately, sending this signal occasionally.

If you see something in error log, please let me know, or send a screenshot.

I also might suspect Doze Mode might getting kicked in (if you are using Android 6 and above). In that case you should place Muzecast in Whitelist of apps to prevent from getting optimized. That setting should be in Battery settings of Android. I cannot force Muzecast to be automatically placed in Doze whitelist. Google does not allow it with penalty of removing app from the store.
Thank you.

Muzecast Support.
gguerra333 Offline
#3 Posted : Monday, April 24, 2017 11:18:54 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Thanks

No errors in the log on the specific days/times that this happened.

I did turn battery optimization 'off' for Muzecast, we'll see if that helps.

As for headphone connection, no interruption. Playback simply just stopped (paused), I turned screen back on, press play and it started playing again.

Bluetooth remained connected. I was using BT ear phones. Playback stopped, I press 'play' on BT earphones, playback started immediately without even looking at the screen.

It is Nexus 6 phone with Android 7.1.1 if that helps. It could be the OS update itself causing something.

I don't remember installing any apps recently that would have caused this.

I have restarted server and phone.

I am re-testing right now using just the speaker on the phone. Will report back.

Edited by user Tuesday, April 25, 2017 3:28:20 AM(UTC)  | Reason: Not specified

gguerra333 Offline
#4 Posted : Tuesday, April 25, 2017 5:21:54 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
I have been testing it with just the speaker on the phone and on Wifi. I have the screen set to remain ON during playback and have the phone next to me on my desk while it is playing. Yes, it pauses in the middle of the song, I press play and it starts again. This is a pause, because the 'play' button appears with the arrow.

Now it ALSO sometime stops at the at the end of song and never goes to the next one. I can swipe and the next song starts, but this is becoming worse. The now playing screen acts like it is still playing the song, but it's at the end of the song and never advances.

It doesn't do it on every song, sometimes it will play a few songs before it happens.

It may have something to do with Android 7? It seems that things like this happen every time there is an update to Android. I have not installed any apps that would affect it.

The app has become unusable for me now and I have been using it for years. Over 1.5 years on this phone I have now and several on my old phone.

Should I uninstall the app and re-install?

What will happen to all of my downloaded songs if I do this?

Is there a cache cleanup or something similar I can do?
Muzecast Support Offline
#5 Posted : Tuesday, April 25, 2017 6:08:20 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
If you uninstall Muzecast, all cached and downloaded songs will be removed from your device.

I am on this issue trying to re-create it. I suspect one more thing, which will be fixed in upcoming release.

Also, could you let me know what sound quality settings you have and if ExoPlayer is turned on or off in Streaming Settings of Muzecast.
Thank you.

Muzecast Support.
gguerra333 Offline
#6 Posted : Tuesday, April 25, 2017 6:47:31 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Sound Quality settings are Optimal on both Mobile and Wifi.

Exoplayer is ON

Muzecast Support Offline
#7 Posted : Tuesday, April 25, 2017 7:01:55 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
Try to turn exoplayer off
Thank you.

Muzecast Support.
Muzecast Support Offline
#8 Posted : Tuesday, April 25, 2017 7:12:22 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
When ExoPlayer is turned ON, streaming is done using MP3 VBR. The current version of Muzecast Streaming server creates MP3 VBR file, which ExoPlayer might not read correctly.
Information, such as duration of the song. ExoPlayer depends on device codec and some devices, just cannot properly handle MP3 VBR file without VBR header.

Upcoming version of Muzecast Streaming server is going to create complete VBR MP3 file with header (initial song playback might be delayed by a couple of seconds because of this). In that case any player will be able to handle it properly.

When ExoPlayer is turned OFF, streaming is performed using OGG format. That format has no issues with VBR and any player can handle it properly.

Now I assume that was the main reason, why playback was stopping on your device.
Thank you.

Muzecast Support.
gguerra333 Offline
#9 Posted : Tuesday, April 25, 2017 9:32:55 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
I turned Exoplayer OFF, reset the app and it is still happening. I do have some more clues however.

I paused a song manually and it acts exactly like when the app does it on it's own. , time elapsed shows 0:00, I press the play button, playback starts and then shows the actual time elapsed. Also, I have Stay Awake ON, the screen turns off when playback is paused which is normal (I think). The playback pausing towards the end of the song does not seem to happen when CrossFade is OFF. Still pausing in the middle though.

I am thinking of uninstalling app anyway regardless and try that.

As for my downloads, could I move them out of their folder with ES File Explorer, re-install the app, move the songs back into their place?

This is the location indicated in the settings
/Android/data/com.vorlan.domedj/files/music/Muzecast

I have 2569 songs using 10695 mb

As I understand it, they are converted to OGG format? I have mostly MP3's and some FLAC's. A few others that I can't remember.

Any other ideas?

Thanks
Muzecast Support Offline
#10 Posted : Tuesday, April 25, 2017 9:53:51 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
Pointers to these files are stored in Muzecast local to device database. Copying files will not help.

Do not yet try to uninstall the app.

Are you using official Google Android or Lineage OS?

If Lineage OS, I will try to reproduce that issue on this OS on one of my devices to see if it is OS specific.

This week I am going to publish updates to both Server and Player. After that, let's see, if problem still exists. I did some adjustments to Audio Focus as well as VBR headers for MP3. These 2 fixes might help with that problem. I am just guessing, because I was not yet able to reproduce the issue you are having.
Thank you.

Muzecast Support.
gguerra333 Offline
#11 Posted : Tuesday, April 25, 2017 9:56:58 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Everything is stock. Android is from google I would assume.

Thanks, I will wait for update.

Muzecast Support Offline
#12 Posted : Thursday, April 27, 2017 5:55:59 PM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
Latest releases of Server and Player/Streamer are posted.
Thank you.

Muzecast Support.
gguerra333 Offline
#13 Posted : Friday, April 28, 2017 3:37:58 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Thanks, I got my app from Amazon. Will that be posted soon?
Muzecast Support Offline
#14 Posted : Friday, April 28, 2017 3:46:32 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
It is posted on Amazon too. Amazon store might delay rolling it out. Usually app becomes available after about 2 days on Amazon store once it was updated. I just check the store and it shows latest version 7.1.4. You could go and try to download it.
Thank you.

Muzecast Support.
gguerra333 Offline
#15 Posted : Tuesday, May 2, 2017 3:52:06 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
Sorry, the app is still pausing every 2 or 3 songs. I press play and it start rights back up again.

I am going to uninstall and reinstall the app. I really do not care about the downloaded songs. I never use the app in offline mode. I already have the songs on my server anyway. If the problem still exists after this then I know it is the OS. I am not happy with this OS anyway. Some time back, I upgraded my phone to Nougat 7.0 and it was OTA. I was not happy with it. It was very slow, since I was never offered the OTA for 7.1.1 I sideloaded it.. Well it is buggy, it drains the battery and is also very slow. Then I found out google was actually downgrading users to 7.0 from 7.1.1. I liked Marshmallow much better. I am probably going to downgrade but I will have to wipe my phone to do it. For now I will just try uninstall/reinstall Muzecast. I will let you know how it goes Thanks, I appreciate it.
Muzecast Support Offline
#16 Posted : Tuesday, May 2, 2017 3:58:56 AM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
You can try https://download.lineageos.org/shamu

I was suspecting that there might something in Android, and yes Google rolled back 7.1.1 for Nexus 6. Let me know how it goes. For now all test devices and emulators for each and every version are passing for Muzecast. That is why sometimes testing might take several days, because I am running multiple devices 24/7 for several days to make sure playback goes without a hitch.
Thank you.

Muzecast Support.
gguerra333 Offline
#17 Posted : Tuesday, May 2, 2017 4:47:00 AM(UTC)
gguerra333

Rank: Advanced Member

Groups: Registered
Joined: 10/25/2013(UTC)
Posts: 52

Thanks: 1 times
I uninstalled and reinstalled Muzecast and it's not pausing anymore. I am going to just let it run to see if the problem has gone away but I am still not happy with Nougat. Going on about the 6th song with no pausing, so it looks like the problem has stopped? We'll see.

I've always kept this phone stock so I could get OTA and security updates. It doesn't matter now, and I don't mind using custom ROM's but am wondering if Shamu is any better than stock with the problems I am having with Nougat, mainly running slow and battery drain. Battery life was much better on Marshmallow and it was way more responsive. I hate charging my phone all the time. I didn't need to before.

Thanks again for the help





Muzecast Support Offline
#18 Posted : Wednesday, June 21, 2017 5:07:51 PM(UTC)
Muzecast Support

Rank: Administration

Groups: Registered, Administrators
Joined: 9/27/2010(UTC)
Posts: 1,099
United States
Location: United States

Thanks: 14 times
Was thanked: 135 time(s) in 128 post(s)
Pushing update, which fixes random pauses of skipping song in the middle of playback on some devices.
Thank you.

Muzecast Support.
Users browsing this topic
Guest (3)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.